Bwidget Source Code
View Ticket
Not logged in
Bounty program for improvements to Tcl and certain Tcl packages.
Tcl 2019 Conference, Houston/TX, US, Nov 4-8
Send your abstracts to [email protected]
or submit via the online form by Sep 9.
Ticket UUID: 2910682
Title: yaml's dict package needs
Type: Bug Version: None
Submitter: dgp Created on: 2009-12-08 13:39:10
Subsystem: yaml Assigned To: kanryu6
Priority: 5 Medium Severity:
Status: Closed Last Modified: 2013-07-04 17:43:47
Resolution: Not Applicable Here Closed By:
    Closed on:
Description:
Testing tcllib-1.12 with Tcl 8.4.19, I see:

[*   ]  [8.4.19]  yaml                  Error in huddle.tcl: bad subcommand "with": must be append, create, ...

The [dict with] command is not part of Tcl 8.4, and
the [package require dict] is apparently getting a
version of the dict package not recent enough to
have the required subcommand.  Adding a version
requirement should help guard against this.

Also, the stanza,

if {$::tcl_version < 8.5} {
    package require dict
}

is buggy.  Use [package vcompare]
instead of trying to treat version numbers
as if they were real decimal numbers.
User Comments: kanryu6 added on 2009-12-17 21:37:03:
thank you.
I modified about this.